Why is my Ethernet not working?

Options
Sebastian103
edited January 2022 in Networking & Security

Hey everyone, uh first time posting on a forum but Microsoft and my ISP seem to think this is neither of their problems and I do not have money to spend on tech support that may or may not work. Anyway a while back I reinstalled windows, because I actually got a liscens for once, and ever since then my ethernet (which is over a Netgear Powerline adapter) does not work properly. On a fresh boot the ethernet will give "invalid IP configuration" and "no default gateway" errors upon troubleshooting. What makes this problem even more infuriating is that once I RESTART my computer, the ethernet is magically fixed, but again, upon a fresh shut down and startup, it is broken again. For the past few months I have had to go through a power on and restart cycle everytime I use my computer. I game a lot so the ping from the ethernet is super necessary, my wifi just can't hold up.

PS: I have tried MANY MANY "solutions" already; The multitude of command prompt DNS/IP resets, driver uninstalls and reinstalls, moving the powerline adapter, and even REINSTALLING Windows...To no succes. The only thing I haven't tried is having a direct connection to my router; this would just be a HUGE hassle as the router is in another room, super long ethernet cords are well super long, and even running one through the attic is just not up my ally, and having a long ethernet cord running along the floor to antoher room sounds like the wrong way to fix this issue


edit: Connected straight to my router and the same issues continue to happen

Any new suggestions would be appreciated.

Answers

  • GavinT
    Options

    How old is the house? Also it isn't plugged into any surge protector, right?

  • The house isn’t old but an update for you is that I tried a straight connection to my router, same exact issues there
  • PowerSpec_MikeW
    PowerSpec_MikeW PowerSpec Engineer
    5 Insightfuls First Anniversary First Comment 5 Awesomes
    Options

    @Sebastian103

    We'll need some more information to figure out what's going on here. The next time this happens, go to an elevated command prompt and type: ipconfig/all

    I just want to verify we're getting a 169.254.x with no Gateway.

    Post the information here for your ethernet adapter. Next try this from command line: netsh interface show interface

    This will show you the interface name. Try to disable it and re-enable it.

    Disable: netsh interface set interface name="<Interface name>" admin=DISABLED

    Enable: netsh interface set interface name="<Interface name>" admin=ENABLED

    See if it picks up the connection after this. Exclude the <>'s, but you will need the quotations for the interface name. As an example if the name was Local Area Connection 2: netsh interface set interface name="Local Area Connection 2" admin=DISABLED

  • Sebastian103
    Options

    Hello again 😅 I know this response is very late and I haven't given any feedback for a while, I have been very busy looking for a job and moving recently and during all of that my issue seems to have fixed itself?? The worst way a problem can be fixed I know but just wanted to thank you guys for trying to help me out!

We love seeing what our customers build

Submit photos and a description of your PC to our build showcase

Submit Now
Looking for a little inspiration?

See other custom PC builds and get some ideas for what can be done

View Build Showcase

SAME DAY CUSTOM BUILD SERVICE

If You Can Dream it, We Can Build it.

Services starting at $149.99