Bad mobo or processor? Can't detect any storage and slow to reach BIOS



  • i5-12400
  • Corsair 2 x 16GB DDR4-3200
  • EVGA 650GT 80+G
  • 128 GB NVMe M.2 2280


Assembled everything carefully last night. Plugged in, switched on, lights came on and fans spun up. Started celebrating. Then noticed the display (connected via HDMI) showed just an underscore, then remained completely black for awhile. During this time, the mobo showed a white light for VGA. I waited, and eventually after several minutes, the VGA light went away, and a green light came on for BOOT. Then the display flashed the MSI POST screen for a fraction of a second, and the UEFI appeared. The RAM and processor were correctly identified. But it didn’t even acknowledge that either storage was hooked up, just said all storage slots were empty. The SATA HDD is connected to one of the ports on the mobo and has power from the power supply. I poked around the settings to see if there was something related to storage detection but found nothing relevant. The mobo has 2 slots for an M.2 so I tried moving it to the other slot and it still didn’t detect it was connected. I put in my USB to install Ubuntu and I was able to load into it, but the setup couldn’t detect any storage connected either, so I couldn’t begin the install. Any help is appreciated. Thanks!

Attempted fixes:

  • Checked all cables were plugged in correctly
  • Tried both HDMI ports
  • Tried M.2 in both slots on mobo (M.2 used to be in a laptop and worked fine)
  • Looked through BIOS settings (any suggestions on specific settings to check would be great)


We love seeing what our customers build

Submit photos and a description of your PC to our build showcase

Submit Now
Looking for a little inspiration?

See other custom PC builds and get some ideas for what can be done

View Build Showcase


If You Can Dream it, We Can Build it.

Services starting at $149.99