RTX 3080 Issue

I have installed a new RTX 3080 into my system. The computer powers on fine, but will not go past the Bios loading screen. Going back to my old GPU, a GTX 980TI, fixes everything, and everything boots up fine. But on the 3080, I am stuck perpetually on the Bios loading screen.

I have updated my motherboard bios to the most recent version released by the manufacturer. It has not fixed it. I have tried resetting my motherboard. It has not fixed it either. I had this issue with an EVGA RTX 3080, so I sent it back, got an ASUS STRIX RTX 3080 and am having the exact same issue. It is not an issue with the gpu. 

Please help me. I want to enjoy my new graphics card but my PC will not move past the motherboard bios loading screen. There must be some issue or setting in my system that is causing this issue. My old GPU was a GTX 980TI, and I am upgrading to a RTX 3080. Because both are Nvidia, I did not uninstall drivers, just updated them to the most recent version. Any help, please. This issue has been the bane of my existence. I have attached the parts of my setup below:

CPU: AMD Ryzen 5 5600x
Motherboard: MSI B550-A PRO
RAM: 16GB Corsair Vengeance DDR4 3200MHz
SSD: Samsung 980 M.2 1TB and 500GB
PSU: Cooler Master MWE Gold 750watts


We love seeing what our customers build

Submit photos and a description of your PC to our build showcase

Submit Now
Looking for a little inspiration?

See other custom PC builds and get some ideas for what can be done

View Build Showcase


If You Can Dream it, We Can Build it.

Services starting at $149.99