New PC will not post

edited August 2022 in General Discussion
Hello, just put together a Z690 w/ 12700k, RM850, 3070 Ti, 5600Mhz Dominator DDR5.

pc will not post. Cannot get into BIOS.

Asus Maximus Hero Z690. Followed the instructions multiple times to update bios using flashback.

BIOS light indicates it successfully updated. Same results. Tried reseating everything. 

Seems like an issue with the ram. I have four sticks and tried every combo in the A2 slot and two in the A2B2 slots. 

Same results. PC will not post to BIOS. 


  • w8deywins


    Thanks for reaching out! From what we have seen so far in the industry is that z690 MOBOs/CPUs do NOT like it when all 4 slots are populated and typically cause crashing and instability on DDR5. Have you tried just 2 RAM sticks installed instead of all 4? I would try this first if you haven't and this should get you a POST at least. Also from what we have heard is that the fastest DDR5 isn't as stable either, so I recommend sticking with the 5600mhz RAM kit. Another thing to note, the z690 Maximus Hero motherboards did have capacitor issues when they first released so hopefully you're not using one of those older boards(“The issue potentially affects units manufactured in 2021 with the part number 90MB18E0-MVAAY0 and serial number starting with MA, MB, or MC.”). If you purchased your board recently, you're all good on this.

    I hope this helps, thanks for shopping with Micro Center!

    Best of luck!🎮️

  • Ian

    You can also run through our guide here as it does have a lot of helpful tips that can help get a new PC up and running!

We love seeing what our customers build

Submit photos and a description of your PC to our build showcase

Submit Now
Looking for a little inspiration?

See other custom PC builds and get some ideas for what can be done

View Build Showcase


If You Can Dream it, We Can Build it.

Services starting at $149.99