Recent purchases of Silk PLA won't stick to bed



I'm of course printing Mandalorian armor for Halloween, and had some a few rolls of unopened silk PLA to print the helmet and one of the shoulder parts. It worked perfectly.

Ran to Microcenter to pick up 8 more rolls, and I can't for the life of me get the new rolls of Silk PLA to stay stuck to the bed.

I can happily print PLA and PETg without a problem - I've been 3-D printing since 2014, and am now printing on a 415x415x290 HevORT, which has a 3 Axis self leveling Z.

Z-Bed is level

Tried bed temps from 60 to 70c

Nozzle is a .4 on an HextrudORT with a Phaetus Dragon hot end.

Nozzle Temp tried between 220 and 230

Print speed is 90mm/sec - I've tried knocking it down to 60mm/sec, with an underspeed of 80% for the 1st layer.

I print on a glass bed, using AquaNet Hairspray (purple can). No go. I've also tried bare glass, still the same, print detatches.

It seems like they may had changed the formulation for the filament, as I printed several rolls of this in the same color (Silk Pewter) and other colors earlier this year without a problem.

Any ideas on how to get this to stick? I've never used the Puple Glue sticks, but am about to give that a try.


We love seeing what our customers build

Submit photos and a description of your PC to our build showcase

Submit Now
Looking for a little inspiration?

See other custom PC builds and get some ideas for what can be done

View Build Showcase


If You Can Dream it, We Can Build it.

Services starting at $149.99