Does anyone know why or have a fix for Asus TUF RTX4080 Screen Sporadically Blinking?


I grabbed a Asus TUF 4080 a couple weeks ago and since I've installed it, my displays seem to sporadically blink to black for less than a second then goes back to normal. It seems to primarily happen when I'm playing games (but maybe it happens when I'm not as well and I've just not noticed yet, since I don't tend to stare at my PC unless I'm playing games). I previously still had a 1070ti and never had the issue. Other than that, there seem to be no other graphical issues - at first I thought I was just blinking myself and being hypercritical, but that's not the case lol.

I'm running a dual monitor setup with a TUF Gaming Z690-Plus motherboard.

So far, I've tried removing / reinstalling the card & doing a clean install of all the GPU drivers, but the issue is persisting. All other drivers are also up to date.

Might be worth noting that there was some coil whine when I first installed the card, but that seems to have gone away on it's own - nothing else abnormal that I've noticed.

Any ideas?


  • Ian


    Sounds like you've done most of the troubleshooting you can do already. You can try other cables between your PC and monitor and see if that might do anything, but this is more pointing towards something wrong with the actual hardware at this point.

  • Kongo

    Disclosure: I'm not an expert, but desperate enough for people connections to be hanging out in Microcenter community. I've read about a couple issues on 4090s and 4080s being solved by locking refresh rates in the Nvidia control panel and in Windows display settings. The fact that it happens to both monitors simultaneously probably rules out bad DP/HDMI cables & connections. A couple of other tests I can think of: do the monitors do that when gaming in windowed mode? Also, what power supply are you rocking? 4080s draw a lot of power when going full tilt in games. If all of that checks out, maybe check temperatures with MSI Afterburner? Going way out in left field, maybe also try updating the firmware in your monitors?

  • Thanks for the replies! I’m rolling with an 850W PSU. I’ve also tried locking them in at lower frame rates in the nvidia control panel,  also with a different 2nd monitor, and connected via hdmi instead of DisplayPort.  I haven’t checked a/ afterburner, does seem like if I don’t have two monitors plugged in, it seems to go away, so I’m thinking it must be hardware related. 
  • PowerSpec_MikeW
    PowerSpec_MikeW PowerSpec Engineer
    5 Insightfuls First Anniversary First Comment 5 Awesomes


    I would try going into your BIOS, and setting the PCIe x16 your GPU is installed in to Gen3, see if the issue persists.

We love seeing what our customers build

Submit photos and a description of your PC to our build showcase

Submit Now
Looking for a little inspiration?

See other custom PC builds and get some ideas for what can be done

View Build Showcase


If You Can Dream it, We Can Build it.

Services starting at $149.99