Issue w SSD enclosure/compatibility


I have a Lenovo X1 Carbon 10th gen using Win 10. I have an external SSD (Samsung SSD 980) that I used with the previous Lenovo laptop (9th gen). With the current computer, the SSD enclosure shows that it has power but the computer does not recognize the connection/drive. I called Lenovo and they told me that it's likely that only certain enclosures will work; they couldn't tell me which ones would work. Interestingly, this SSD worked fine on the X1 9th gen computer.

So: are there any enclosures which WILL work and be recognized by a X1 10th gen laptop? Or, do I have to go through trial and error?

Thanks in advance,

Best Answer

  • GaminNerd
    GaminNerd ✭✭
    First Answer First Anniversary First Comment
    Answer ✓

    Does the ssd have any boot partitions on it or Operating system installs on it, or any drivers from the 9th gen system? 10th gen and 9th gen are NOT compatible with each other when if comes to hardware, software, or really anything. I am not a tech genius but If you have somewhere else to store the files for now I would suggest wiping the drive and trying to put all the files back on it and see if it works. Let me know if it does!


  • PowerSpec_MikeW
    PowerSpec_MikeW PowerSpec Engineer
    5 Insightfuls First Anniversary First Comment 5 Awesomes


    Can't think of any reason why this would be an issue on the newer version of the X1 Carbon, with a known working USB-C NVMe enclosure. Check Disk Management, see if the drive shows up there, maybe it's just mounting properly. Check Device Manager, connect the drive, see if it refreshes and detects the enclosure. If it does, kill USB selective suspend in your advanced power options, and reconnect it.

  • Thanks!

    In Device Manager, it doesn't show up.

    A Lenovo tech support rep told me he had a similar issue with his desktop and had to try the SSD in the store with a variety of enclosures; he finally found one that worked. I'm hoping I don't have to go through that...I tried a Sabrent (worked on my 9th gen machine) but it doesn't work on the 10th gen.


  • PowerSpec_MikeW
    PowerSpec_MikeW PowerSpec Engineer
    5 Insightfuls First Anniversary First Comment 5 Awesomes


    Do you have a USB hub, preferably powered, you can put between the PC and enclosure to test?

  • Thank you all for the feedback!

    GaminNerd: After your suggestion, I was able to get a partition manager program to see it and found there seemed to be a hidden partition with the OS. Once I got rid of that, I was able to get the computer to recognize the drive and get it formatted and set up nicely.

    Thank you for suggestions!

We love seeing what our customers build

Submit photos and a description of your PC to our build showcase

Submit Now
Looking for a little inspiration?

See other custom PC builds and get some ideas for what can be done

View Build Showcase


If You Can Dream it, We Can Build it.

Services starting at $149.99