Asus Z390P Motherboard lights up but no power


I took my motherboard to a shop yesterday he used his power supply (Didn't Bring Mine) it powered up he was in the bios it worked fine when i returned home I did everything the guy did at the repair shop (Motherboard light up but that's it) i couldn''t get any results CPU fan was spinning (Now it's not even doing that) but it didn't power on like it did at the repair shop. I checked the power supply ( Jumped Pins 3/4) that's working fine. When i jump the power button on the board the power supply makes a clicking noise I tried resetting CMOS removed the battery no results i'm out of ideas


  • PowerSpec_MikeW
    PowerSpec_MikeW PowerSpec Engineer
    5 Insightfuls First Anniversary First Comment 5 Awesomes


    Clicking noise generally means it's shorting on something. Disconnect everything except the 24 pin just to test. If it won't power on then, you know it's the PSU, since the board previously tested fine. If it does work with the 24 pin, add the 8 pin CPU, add your GPU PCIe, then start adding peripherals.

We love seeing what our customers build

Submit photos and a description of your PC to our build showcase

Submit Now
Looking for a little inspiration?

See other custom PC builds and get some ideas for what can be done

View Build Showcase


If You Can Dream it, We Can Build it.

Services starting at $149.99