Powerspec B734 gets hung up on PowerSpec splash screen when trying to boot to bios/uefi


I have been working to configure several brand new Powerspec B734 pcs for my employer. When I try to get to Bios on any of the PC's the computer instead gets hung up on the PowerSPec splash screen and won't move any further. When I don't attempt to enter bios, the computer is able to properly boot to windows. Does anybody have any advice to fix this issue?




  • I was starting to go a bit wacky. I had tried everything I could think of. Eventually I tried switching monitors and for some reason that worked. I was using a curved screen monitor and for some reason that was leading to the PC hanging up on the "PowerSpec" splash screen and keeping it from booting to bios. On the non-curved monitor, it is working correctly.

  • PowerSpec_MikeW
    PowerSpec_MikeW PowerSpec Engineer
    5 Insightfuls First Anniversary First Comment 5 Awesomes

    @donnie_reynolds '

    ASRock boards tend to be a little odd in that they'll halt on a VGA error if they can't properly detect the monitor sometimes, instead of continuing on like most boards. We can look into it. What model was the monitor that was giving you a problem?

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

We love seeing what our customers build

Submit photos and a description of your PC to our build showcase

Submit Now
Looking for a little inspiration?

See other custom PC builds and get some ideas for what can be done

View Build Showcase


If You Can Dream it, We Can Build it.

Services starting at $149.99