Access BIOS on boot with PowerSpec G443


Just bought a PowerSpec G443 and am really liking it so far. However, I've been unable to access the BIOS when booting. I've tried pressing delete button repeated on restart. Systems seems to freeze (on, LED lights on, no advancement to anything including windows 11 or the BIOS menu, screens are blank).

I have two displays connected to the NVIDIA 4070-- one via HDMI and the other via DisplayPort (using an HDMI to DisplayPort active adapter).

I have Bluetooth keyboard and mouse. However, I connected the included USB keyboard for this.

I've also tried alternating between F8 and F11 per the restore instructions included (but no USB drive installed). All I ever get is blank screens and no advancement.

(I can power down and turn on to successfully load into Windows).


Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

We love seeing what our customers build

Submit photos and a description of your PC to our build showcase

Submit Now
Looking for a little inspiration?

See other custom PC builds and get some ideas for what can be done

View Build Showcase


If You Can Dream it, We Can Build it.

Services starting at $149.99