PowerSpec 1510: SSD_2 not appearing in BIOs when there is an SSD installed.


I bought a second SSD to expand the memory on my Powerspec 1510 laptop. I inserted and screwed down the new Seagate SSD into the SSD_2 slot. When I booted the PC, I was unable to see the drive in the BIOS. I went to Disk Management in the Control Panel and also found that I could not find the drive to be formatted or to have a new partition created.

I have tried swapping the existing Samsung SSD into slot 2 and still did not find it in the BIOS. The new SSD did appear when I put it into Slot_1. So I know that there is nothing wrong with the new SSD, but definitely something off with SSD_2. There doesn't appear to be anything broken when looking closely at the slot, so I tried upgrading the BIOS, but have not been able to run the flash tool as it is giving Error 451: The CPU does not have write access..." when I try to flash the BIOS.

Is it possible to install the news SSD, or is this something that is potentially blocked with PowerSpec laptops?


Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

We love seeing what our customers build

Submit photos and a description of your PC to our build showcase

Submit Now
Looking for a little inspiration?

See other custom PC builds and get some ideas for what can be done

View Build Showcase


If You Can Dream it, We Can Build it.

Services starting at $149.99