Motherboard wont post when 2nd RAM stick is installed

I bought a new bundle of Ryzen 7 7800X3D, Gigabyte B650 GAMING X AX V2, and Flare 5 32GB a week ago. No matter what I do, the PC won't post if I put the 2nd RAM in B2 or any other slot apart from A2. I have tried various methods, such as resetting the CMOS, performing a MEM test, and reinstalling the CPU. Everything works fine with one RAM in the A2 slot. I have tried to wait overnight to see if the motherboard posts and shows the display, but the motherboard is stuck on the same DIMM red light. I even swapped the RAM sticks to see if that works, but it's the same issue. When I remove the 2nd RAM from the motherboard, everything starts working again.

What are my options? I also got coverage on the CPU and Motherboard, and I am still under the 15-day deadline to return if required.


We love seeing what our customers build

Submit photos and a description of your PC to our build showcase

Submit Now
Looking for a little inspiration?

See other custom PC builds and get some ideas for what can be done

View Build Showcase


If You Can Dream it, We Can Build it.

Services starting at $149.99