New Build won't go to BIOS POST


This has been the bane of my existence. This should have been a relatively easy build (I've done this before years ago).

Helping my son build a gaming PC. We're on the 2nd Asus motherboard - first one got ruined with bent CPU pins while putting it together - long story.

Anyway, we have it together and I'm 100% sure that everything is connected correctly after the pin fiasco. I've done everything that's recommended on Microcenter's site and every website I've come across regarding the BIOS Post not kicking off from initial power up.

Still nothing. Fans power up, including the AIO, keyboard lights up, but no signal to the monitor. I've tried it with the video card and then went bare bones - no video card, one stick of RAM and connected straight to the motherboard. Nothing. Fans and lights on but no beeps and no signal to the monitor.

I'm stumped and looking for ideas.

Here's the specs:

ASUS Z790-V Prime AX Intel LGA 1700 ATX Motherboard

ASUS TUF Gaming 850 Watt 80 Plus Gold ATX Fully Modular Power Supply

Crucial P3 Plus 2TB 3D NAND Flash PCIe

Intel Core i9-12900K

G.Skill Ripjaws S5 Series 32GB

Gigabyte NVIDIA GeForce RTX 4070 Windforce 

As I said, I've tried EVERYTHING. I've been at this for 6 hours and am so done. The BIOS on the board is relatively recent from a couple of months ago - I checked. And as I said I went through all the steps listed on Microcenter's site that they recommend to do when the initial BIOS won't boot. HELP!


We love seeing what our customers build

Submit photos and a description of your PC to our build showcase

Submit Now
Looking for a little inspiration?

See other custom PC builds and get some ideas for what can be done

View Build Showcase


If You Can Dream it, We Can Build it.

Services starting at $149.99