Screen blur — Micro Center

Screen blur

I just built a gaming rig with components from Micro Center. Team was fantastic supporting me throughout the selection, purchase and post-build process.  My mouse blurs on the main screen and my game (Rainbow Six Siege) blurs when I turn in the game.  I've made sure "Display pointer trails" is disabled. Changed the motion blur setting in the game's .ini file to 0.  My rig is a Ryzen 5 3600 on an Asus Prime 570-P motherboard, 16Gb of 3600mHz Ram, with a Gigabyte Geforce RTX 2070 Super Gaming OC GPU.  I replaced the GPU last weekend at our Micro Center.  Really bummed given the hardware, time and money I've put into this rig. Any help would be greatly appreciated. As a note, the rig initially wouldn't post when using G.Skill 3600 16Gb RAM. Again, thanks to our Micro Center, they replaced the RAM with Ballistix Elite 3600.

Comments

  • Hello @Skyraider, thank you for joining the community page! Now for the gaming rig, has all the drivers been installed and updated to the latest version? Since you are using a Gigabyte Geforce RTX 2070 Super, you can open GeForce Experience (download it if you don't) and it will auto-detect for any driver updates and will allow you to download and install any updates that NVIDIA has for the video card. 
  • SkyraiderSkyraider
    edited April 22
    Hi @TSAustinM!  Yes, I downloaded the drivers. The only area I'm not solid on is if I need to or how to download drivers for my ASUS 278QR 144mHz Monitor. It has a generic plug & play driver in place right now. I've seen comments that it is plug & play and doesn't need anything else, but I'm ignorant there.  I had set the X570 into overdirve mode but backed it off to see if that helped. Didn't. It could be me. My work Mac and secondary laptop has the same qhost image when I move the mouse quickly. Speaking of, I have my monitor set on 165mHz since it can overclock. I tried backing it off to 144mHz with no change.  Thank you for your time and any guidance you have. This one seems like a bit of an edge case. 
    One thing I thought about was if the latest Nvidia drivers were causing it.  I haven't tried an earlier version. 
  • Are you using a wired or wireless mouse? You can also open Mouse Properties and check to see if enhance pointer precision is enabled under Pointer Options. You can even try to check for drivers for the mouse since some brands have a driver for their device. 
  • Good morning @TSAustinM!  I'm using a Glorious Model O wired mouse.  I actually disabled the pointer precision under pointer options. That was a recommendation from a few Siege streamers.  I can enable it and see if that helps. I'll have to see if Glorious has a mouse driver.  The issue is bigger than the mouse blur. It's more Siege blurring when I turn.  I'm trying to see if it's, again, just me or if others are getting the same blur.  I'm just being picky.  I so appreciate your time and guidance!  
  • Hello @Skyraider!
    I'm assuming you have G-Sync enabled?  Have you tried disabling it?  Is it only happening with Siege?  Have you tried any other FPS games to see if there is a similar issue?  
Sign In or Register to comment.