Asus Tuf B450m plus build won't boot from USB to install windows. First build.

Options
I know I must be doing something wrong, but I'm not sure what. I change the boot order in BIOS and it goes right back. I mash F8 on wakeup and select the usb there and still nothing. USB is a Kingston that I created an install on from the Microsoft website (on a Mac). I'm two seconds from going to target and buying the media installer they sell... Is it bc I'm doing it on a Mac?

Comments

  • TSTonyV
    TSTonyV ✭✭✭✭✭
    First Anniversary 5 Likes First Comment First Answer
    edited May 2020
    Options
    Hello @Keegan! Welcome to the Community.

    How exactly did you create the media from your Mac? If you just downloaded the .iso file and transferred it over to the drive, that won't work unfortunately. 

    You actually have to install the ISO on the USB drive. On a Windows PC you can download the Media Creation Tool from Microsoft and it will do it all for you basically, but on a Mac you have to go through a different process. You should be able to use Boot Camp Assistant to do it, try following this guide:

    https://www.windowscentral.com/how-create-windows-10-installer-usb-drive-mac
  • Keegan
    Options
    Hi Tony,
    I performed the bootcamp installation media action, but it still wasn't working. I eventually created the install tool on my dad's HP and it ended up working. I'm all set, but thanks for replying!
  • PowerSpec_MikeW
    PowerSpec_MikeW PowerSpec Engineer
    5 Insightfuls First Anniversary First Comment 5 Awesomes
    Options
    Try this, in your BIOS look for the boot menu. There should be setting there called CSM, it'll be disabled by default. Enable this, save and exit then see if the drive is detected. ASUS typically uses F7 or F8 as a boot menu option.
  • jadehs
    Options
    I'm having a similar issue and I've tried everything I can find online. I have a Kingston USB and have tried to create the boot drive on my Mac using boot camp, and by doing it manually (erasing and reformatting as exFAT) and dragging the ISO files to the new drive. I've also tried using the Paragon NTFS app. So far I get the same result, I put the boot drive into the new PC (tried multiple USB slots) and it won't recognize it. CSM is enabled and I have selected UEFI Only. I have a Gigabyte B450m DS3H. And unfortunately I don't have access to another Windows PC.
  • PowerSpec_MikeW
    PowerSpec_MikeW PowerSpec Engineer
    5 Insightfuls First Anniversary First Comment 5 Awesomes
    edited July 2020
    Options
    I actually just recently wrote a guide that in the process of being approved, that goes through splitting the wim file on OSX and creating a UEFI bootable flash drive to install Windows 10. It's pretty complicated, as you have to manually format your drive on windows, then remerge the wim files and image with dism, but it does work. Let me see if I can get that out to you.

    Edited: Typo, to install Windows 10. Sorry for the confusion.
  • jadehs
    Options
    TSMikeW said:
     ...UEFI bootable flash drive to install on OSX. It's pretty complicated, as you have to manually format your drive on windows
    Thanks! However just to clarify, I'm trying to create a Windows Boot drive on a Mac to install on a PC, not to install on OSX. I don't currently have a Windows OS available to format the drive. 
  • PowerSpec_MikeW
    PowerSpec_MikeW PowerSpec Engineer
    5 Insightfuls First Anniversary First Comment 5 Awesomes
    Options
    Yep, that's exactly what it's meant to do. There are guides out there that mention formatting ExFAT but some motherboards won't boot from that. With FAT32, the .wim is now larger than 4GB so you can't copy it onto the flash drive. There's a command called split on Unix/Linux that will cut the file in half, then you can put it back together in the windows installation environment and deploy it.
We love seeing what our customers build

Submit photos and a description of your PC to our build showcase

Submit Now
Looking for a little inspiration?

See other custom PC builds and get some ideas for what can be done

View Build Showcase

SAME DAY CUSTOM BUILD SERVICE

If You Can Dream it, We Can Build it.

Services starting at $149.99