No display on monitor — Micro Center

No display on monitor

Hey, I just built my pc it turns on but my monitor says no signal all plugs seem to be in the right place after checking multiple times. I have a Ryzen7 3700x on a msi 570x gaming edge, EVGA 2080super, with a EVGA 650w 80+gold. This is my first build I would really appreciate it if anyone can help.

Comments

  • TSMikeWTSMikeW admin
    We can certainly look into this for you. What are the EZ_Debug LED's on the right telling you?
  • Some on please help!! I have the exact same issue.... Upsetting because the msi x570 is supposed to be "Ryzen Ready' yet im seeing countless builds with the x570 mob and AMD Ryzen 5 CPUS not POST.... The rbg string and all the fans in my system work and stay on, the system does not POST and i am compeltley unable to access my BIOS because there is no display signal coming out. i also am using a 650w PSU, could it be too low to boot this system .. (PS the EZDebug LED lights up the BOOT indicator only, cpu ram and vga all pass the testing during boot, just no display comes out)
  • Make sure your monitor is plugged into your graphics card and not your motherboard.  
  • TSMikeWTSMikeW admin
    Randall is correct. If you're at BOOT the system has POST'ed, it's looking for a bootable device. You should be in the BIOS. Check your video output. Remember, even though all X570 boards have video outputs, only CPU's ending in G(Ryzen 5 3400g, Ryzen 3 3200G) have an APU to allow these ports to function.
  • thank you guys... rather embarrassed I can build a whole PC from scratch and then do something as stupid as plug the HDMI into the MOB not the GPU....... guess thats what happens when you spend hours doing cable management ! thank you guys, PC is running flawless. 
  • IanIan admin
    lamb_22 said:
    thank you guys... rather embarrassed I can build a whole PC from scratch and then do something as stupid as plug the HDMI into the MOB not the GPU....... guess thats what happens when you spend hours doing cable management ! thank you guys, PC is running flawless. 
    No worries, glad to hear that helped! 
  • AlexSAlexS admin
    Just for future reference, (in case you have any friends who run into this sort of issue) we do have a little guide on this sort of troubleshooting :) May be worth a bookmark! 
    https://community.microcenter.com/discussion/2850/what-to-do-if-your-new-desktop-or-monitor-shows-a-blank-screen-on-first-boot#latest
Sign In or Register to comment.