No display port/No HDMI signal — Micro Center

No display port/No HDMI signal

Hi! I bought a prebuilt PowerSpec Gaming Desktop today along with a ASUS ROG Swift monitor. Ive confirmed the monitor works indeed with my gaming console and even my old PC. However, the desktop when attempting to connect to any monitor does not display anything. I have used 2 different HDMI cables, 2 different Display Port cables and even attempted to connect with a VGA cable. Please assist or direct me to how I could possible fix this. I am fairly confident there is something wrong with the PC. 

Answers

  • I bought a built a gaming desktop and having the similar issue. The HDMI port on the back panel seemed to be not working. Verified not issues with and HDMI cable by testing them with another computer. Could this me an issue with the mother board - ASUS TUF B450M-PLUS Gaming motherboard?

  • TSMikeWTSMikeW admin
    Keep in mind a gaming PC is going to have a discrete graphics card located in the lower expansion ports, and all motherboards are going to have onboard video ports. Whether they work or not is the question. Default behavior is if you have a discrete card installed, the onboard video ports don't work.  Make sure you're connecting to the lower GPU ports. It's most likely going to be in a 3x DP 1x HDMI configuration. If you're in this port and you have no video. Check your monitor, make sure you're not using a TV or an old monitor. It may have trouble displaying the resolution the system is outputting. 
Sign In or Register to comment.