Wireless printer will not print from laptops — Micro Center

Wireless printer will not print from laptops

Hello,

I have a Brother wireless printer that has worked well for more than a decade. Last week, I noticed the Brother wireless printer will not print jobs from my personal laptop (Toshiba). I installed the wireless printer software onto another laptop (Dell). However, I encountered the same problem from both laptops: I click "Print" and the light will turn green on the Brother wireless printer. But nothing will print. 

I have tried rebooting the home wireless modem router (still can't print), troubleshooting on my laptop (system found no errors with the wireless printer), restarting the wireless printer (no luck), and resetting the network on the wireless printer. My home wireless modem router shows the wireless printer is connected, and the wireless printer reports a status of a strong and connected WLAN. I even tried disabling and restarting the Print Spool function under Control Panel > Administrative Tools > Services.  I still can't print a document from either laptop. Ironically, I can receive print jobs from my Android smartphone (I select "Print" and the wireless printer comes to life). 

I have exhausted my options. My laptops and smartphone connect to the home wireless modem router. I will appreciate any solutions! I do not want to replace the wireless printer if I run into a similar issue with the network. 

Comments

  • Do you have a USB cable you can use to try plugging the printer directly into your laptops? That would be first instinct. If it can print successfully when using a USB cable, that means it has to be something to do with the wireless communication between the printer and computers.

    You mentioned you restarted your router, you could also try factory resetting your router. You'll have to re-connect your devices to wifi when you do this, but it's worth a shot. 

    I would also check and make sure your computers are set to a private network with network discovery turned on. Go to Control Panel > Network and Internet > Network and Sharing Center > Advanced Sharing Settings. Open the private category and make sure network discovery is selected. 
Sign In or Register to comment.