new B744 hangs on boot — Micro Center

new B744 hangs on boot

with PowerSpec screen. If I disconnect my external drive and use the power switch at back, I can get it to boot then reconnect my drive. I have read that disabling Fast Bootup in Windows 10 is a fix for that..haven't been able to get time for a reboot yet. Anyone have experience with this?

Comments

  • with PowerSpec screen. If I disconnect my external drive and use the power switch at back, I can get it to boot then reconnect my drive. I have read that disabling Fast Bootup in Windows 10 is a fix for that..haven't been able to get time for a reboot yet. Anyone have experience with this?
    @Andrew02467 . Does it boot fine without your external drive connected at all? It's possible that your external drive is causing the system to hang. This is actually fairly common when external drives start to die, and end up causing the system to hang as it repeatedly attempts to access the drive and fails to do so.

    Have you tested the external drive in other systems to see if they boot fine?
  • The external drive in question is about 3 months old, worked fine in the other computer, and is a WD SSD drive that only has data on it. The PowerSpec PC does boot fine without the drive connected. Thus I wondered about the Fast Bootup setting, or, as I read more, possibly needing to adjust the Secure Boot UEFI setting.
  • You're on the right track. Unless there's a hidden boot sector on this drive to cause it, the solution will be a BIOS setting. Fast boot is possible. Also toggle USB legacy support off. You might also test with CSM enabled under "Boot" as well.
Sign In or Register to comment.