Motherboard won't POST — Micro Center

Motherboard won't POST

I recently purchased the parts to build a new system for my parents.  System is comprised of a ASRock B450 PRO4 that is Ryzen 3000 ready(BIOS 3.9), Ryzen 5 3600X Matisse CPU, Corsair Vengeance 16GB DDR4-3200 Ram, WD Black 500GB SSD 3D V-NAND.  Since they will not be doing any gaming, I am just using the onboard video card.  I have all this assembled out of the case to verify that it will POST before installing into the case.  Upon first power-up, the CPU  did spin up and modulate its speed, but got nothing on the monitor even after letting it sit for a couple mins.  Do not get any beeps from the MB either.  Tried both the VGA port and HDMI port to no avail.  Memory is installed in slots A2 and B2 per the MB instructions.  Have also tried no memory and 1 stick with no luck.  Tried SSD installed and uninstalled.  With SSD removed, I even tried another HD that I had laying around.  Any ideas?

Best Answer

Answers

Sign In or Register to comment.