PowerSpec G466: Read if you are having BSODs

First Comment
edited January 2021 in General Discussion
Hi all,

After buying a PowerSpec G466, completing the setup, and downloading a game, I found that the PC would BSOD mere moments into a hectic scene. As it turns out, the BIOS for this PC is set to use XMP with a 3600MHz clock out of the box. This is far above the supported clock rate of the i9-10900KF that it has inside (which is 2933). The easiest way to fix this is to set the "Load XMP Setting" to "Auto" instead of "XMP 2.0 Profile 1". This will default it to the bog standard 2133MHz, which will correct the issue. I have yet to dabble with pushing the limit on the XMP, so I have no idea what (if any) of the higher XMP settings will be stable. YMMV.


  • PowerSpec_MikeW
    PowerSpec_MikeW PowerSpec Engineer
    5 Insightfuls First Anniversary First Comment 5 Awesomes
    Greetings @Axodah

    2933 is highest JEDEC speed. This is what you'll always see on CPU's, either 2933 which is pretty current or 2666. You can push it higher, but 3600 is very aggressive on the current Intel platform and can create stability issues. What I would recommend is to load the XMP profile then decrease the frequency to 3200. This is a safe stable frequency and increase your overall performance.
We love seeing what our customers build

Submit photos and a description of your PC to our build showcase

Submit Now
Looking for a little inspiration?

See other custom PC builds and get some ideas for what can be done

View Build Showcase


If You Can Dream it, We Can Build it.

Services starting at $149.99