Bizarre memory address behavior (problems with Win 10 updates and numerous software installs)

Firstly, the TLDR version for the longer part further down:
Despite all that happens and steps taken, even a brand-new SSD exhibits the memory address issues and fails to update windows. I independently have confirmed my video card works in my 2nd tower. After all that [below] it has to be hardware still right? RAM, MOBO or CPU is all that's left.

The longer version: My purchase reference # in case you need it: 081-P0-13722796
Computer was operating fine from January through the middle of April of this year. I had been doing some renders with Blender and Daz Studio but the Open Hardware program lacks the full configuration file for the 2060 Super and there wasn't a software option for me to increase the GPU fan speed like on my 980ti. Initially I had GPU worry. Still, one afternoon I had a game (MTG Arena) prompted me to update Microsoft Visual  C++ redist update. It never completed successfully. That led to a long spiral of troubleshooting which ultimately led me to a System Restore point prior to the C++ redist install and thus nullifying ever playing that game on that PC again. Any attempt to install now results in a corrupt error. Ok, whatever. Then Blender started crashing post restore point, Daz Studio too... and then browsers randomly crashing pages from a simple mouse wheel scroll [Chrome's "Aw, snap" error for example]. I thought I had Malware that had somehow gotten around Spybot S&D. Then I figured my restore must have been corrupted and the registry is messed up. I try to do Windows updates in case I missed an important one... and the updater just crashes trying to update getting a 0x80003fa error (a code which the internet does not help much with).
I popped in the Windows Install USB and attempted to do a repair. Long % count process and the computer reboots... and the screen says "There was a problem resetting your PC. No changes were made." WOW... um... I go back to the blue screen menu and formatted all partions, even the reserved ones... everything... and reinstalled. Fast-forward 30-45 minutes and it's a fresh install. I go to updates... and I get 0x80096004 error. There was a bunch of other things (it was back in April and I kept notes... this really is the shorter version).
I got in the car and drove and bought a brand new SSD. Popped it in, did the whole install, made sure Windows was activated of course and then the updater. did. not. work. again... No other HDD/SSD or flash media is present or installed (besides the USB installed I had used to put Windows on the machine). The SSD is a SATA, I'm not using M.2 in this build.
It has to be hardware right? So I was able to get Intel's CPU diagnostics tool to work and it said the CPU was fine. I couldn't install the RAM checker I had found because it needed Microsoft Visual C++ redist AND that failed to install again post fresh SSD. Similar issue for a video tester which failed mid-install with a " is missing or corrupt" error. I got so mad I just put the old 2014 i5 PC back together, I still have the Dual Xeon beast for rendering and so I put the new PC on the shelf and there it has sat for 5 months.
I finally pulled it off the shelf and took it to Best Buy for kicks yesterday (because Micro Center is 90 minutes with no traffic, so maybe 2-3 hours each way)... their diagnostics tool USB did not find anything conclusive. They were able to confirm the computer was acting weird outside of the tools they ran. They couldn't really help me beyond that.
So I tried something new (which I should have done earlier) and put the 2060 Super in the dual-Xeon tower and it ran fine. I did some renders on both Daz and Blender and they ran very well but the older Xeon's are not the best at all applications. Games are pretty much out the question. The 9th gen i7 would be much better.
I put the 2060 back in the new CPU machine and formatted this new SSD. After the full install I tried updater again... nope, still bad, still getting the 0x80003fa errors. Then I tried the Windows 10 Troubleshooter.  The troubleshooter said it corrected IS POSTBACK FALSE which is pretty inconclusive.
There was a bunch of manual updater steps I left out, using admin on CMD prompt to stop and start wuauserv, cryptserv and bits (bits said it was already off which was weird). Those steps would allow for updates to start downloading but they still ultimately fail with codes of 0x80070490 and 0c80096004.
If you are still reading, thanks... I'm thinking MOBO at this point but it could be RAM. Just such a painful computer issue.


  • PowerSpec_MikeW
    PowerSpec_MikeW PowerSpec Engineer
    5 Insightfuls First Anniversary First Comment 5 Awesomes
    Greetings @infinitedraw

    You've been pretty thorough so far, but unfortunately there's more to do. You've ruled out the drive, but the problem almost sounds like an end to end error and this could be related to your RAM. The problem here is if it is it may have already corrupted your OS again and you might not solve your problem even if you narrowed it down without an OS install. I would test your RAM individually on a fresh install and try to isolate the issue.  If you're coming up blank remember that the memory controller is on die, it could be your problem as well. 

    Run memtest86 outside of the OS as well:

    Let it run for a while.
  • infinitedraw
    infinitedraw ✭✭
    First Comment Photogenic
    edited September 2020
    Appreciate the response. I have now performed the USB boot with memtest86 on both RAM chips individually. This means two runs of the 13 tests, 4 passes each, and both chips have each passed successfully (zero errors found).
    I'm going to have to do a bunch of tasks I wanted to perform, each with a different RAM chip isolated from the other. The normal stuff I was already trying to do such as installing things or updating Windows. I'm assuming I'll see the behavior on both sets of tasks being the memtest went well. Still, I thought I'd post an update.
  • TSTonyV
    TSTonyV ✭✭✭✭✭
    First Anniversary 5 Likes First Comment First Answer
    If Memtest86 passes that would say the RAM itself doesn't have any problems, so we'd be down to OS, or memory controller problems. 
  • infinitedraw
    Whole new motherboard (from Fairfax Microcenter), got home, installed it, went ahead and wiped the SSD completely and started over.... figured I'd start fresh.
    ...and the problem is still happening. I wanted to just throw the tower out of the room... so ... so... mad. All the symptoms including the 0x80003fa errors, the "Aww... Snap" browser crashes and the missing and when I'm trying to install Blender (or even Steam games). It's so darn frustrating...
    Maybe the Windows USB crapped out but that wouldn't explain how the computer was fine for three months initially.
    If I take the machine to a location (like the Fairfax store) can I leave it there and they just swap parts until it's fixed? At least someone else can see it and say "this shouldn't be happening". Surely paying for advanced troubleshooting is less expensive than me buying new ram, checking everything and probably a new CPU... I would say it really HAS to be one of those two things now.
    If I just go buy those then I would have a whole new computer. I just don't want to admit defeat yet...
  • TSPhillipT
    Hello @infinitedraw
    That would be the last thing I would recommend, a new USB Windows 10 Installation Drive on a new flash drive.  Otherwise, we can definitely take al ook at this if you would like to bring it in to our service desk and we can definitely diagnosis this issue.  

We love seeing what our customers build

Submit photos and a description of your PC to our build showcase

Submit Now
Looking for a little inspiration?

See other custom PC builds and get some ideas for what can be done

View Build Showcase


If You Can Dream it, We Can Build it.

Services starting at $149.99