I need help reinstalling all of the drivers/software after resetting the o/s for Powerspec G356 — Micro Center

I need help reinstalling all of the drivers/software after resetting the o/s for Powerspec G356

After resetting the o/s for my Powerspec G356, I am having problems reinstalling the software listed at http://www.powerspec.com/support/support_archive.phtml?selection=G356

I clicked  on C->motherboard-RGB->PolychromeRGB->iAsrPolychromeRGBSetup(v1.0.42) to install it. I want to control the fan. It installed c:\Program Files (x86)\ASRock Utility\ASRRGBLED.
When I tried to run AsrPolychromeRGB from the bin directory, I got the error: "This utility is not for this platform".  I don't understand this since this is from the software associated with software listed at the powerspec web site for G356.  What am I doing wrong?

I also downloaded the driver for Realtek Audio (http://www.powerspec.com/support/files/psdriver_18l.zip). I unzipped the file.  When I ran the Setup app, I got an error "No driver supported in this driver package". (error code -0001)

Thanks in advance for helping me out.


Comments

Sign In or Register to comment.