Ryzen CPU Not Operating as Intended?

Hi Everyone. Back in March of 2020, I decided to get into PC gaming after 30 years of console gaming. I picked out all my parts online, then headed to Micro Center. But when I got there, I saw a deal on a pre-built ("Powerspec PC"- I believe a G705) that was a few hundred off the regular price. It cost far less than the parts alone would have, and it was just too good of a deal to pass up. So I walked out of the store with a pre-built PC containing a Ryzen 7 2700x, a Powercolor RX 5700xt, an Asrock mobo, and 16 GB of Ram. I got it home and was pleasantly surprised to find that there was no bloatware, and nothing was proprietary (meaning I could upgrade it later). I gamed for 6 or 7 months on the machine without really messing with or checking into anything, and it performed pretty much exactly as expected. Happy gamer!

A few weeks ago, I dropped an RTX 3080 into this machine. For the most part it was a big upgrade, but I was slightly disappointed that there were some games (Control, Watch Dogs: Legion, Metro Exodus, etc.) where I couldn't just set everything at Ultra and count on getting a solid 60 fps (which I'd assumed, perhaps due to my lack of PC gaming experience, that I'd be able to do with a brand new "flagship" GPU). I've since learned that this is somewhat normal for these specific games, but regardless, the experience got me -- for the first time -- to start investigating clock speeds, temps, voltages, etc. on both my GPU and my CPU. This leads me to my reason for posting today...

What I've discovered is that (assuming I'm correctly understanding the readings), my CPU (the 2700x) has all of its cores running at a solid 4.1 Ghz at all times. It doesn't matter what I'm doing -- whether sitting at the Windows desktop with nothing running (besides normal background processes), viewing a Google Chrome page, or running a demanding video game or even a stress-test -- it just runs at 4.1 Ghz constantly. I've checked these readings with a few different tools (like CPU Z and Ryzen Master), and they all agree.

I guess this doesn't really "bother" me. The temps are fine and I'm getting roughly the performance I'd expect in games based on the benchmarks I've looked at online. But still, this isn't how it's supposed to run, is it? Isn't it supposed to settle down during light loads, then boost (maybe even higher than 4.1 Ghz) during demanding loads?

I've never tried overclocking the CPU or anything, nor have I messed with anything in the BIOS (it's all still set however Micro Center set it when they built the machine -- which is pretty much all BIOS items set to "auto"). I couldn't find anyone else online with this specific issue (most problems on forums related to this CPU were either it not boosting high enough, or it not idling low enough, but nobody mentioned having constant clock speeds). But what I did find in forums led me to check my windows power plan setting (which is set to "Balanced (recommended)"), and my minimum processor state (Set to 5%) and maximum processor state (set to 100%). All of that is apparently normal. 

So, I'm fresh out of ideas. Anyone have any clue why my 2700x would be running at a never-ending 4.1 Ghz for eternity? And does it even matter? Am I giving up any gaming performance?

Below are a few images of the readings I'm basing my conclusion on. If it's something very obvious, I apologize. Like I said, I'm pretty much brand new to PC gaming. 



  • JS_MC
    Thanks for the detailed report of what's going on with your system.
    Based on your last image, it looks like you have an automatic overclock set on your CPU. If you click "Auto or Precision Boost Overdrive, and then apply those settings, you should see your clock speed change. You will need to open Ryzen Master with Admin privileges to be able to make these changes.
    Let us know if this fixes the issue you mentioned!
  • Thank you for the reply! I haven't tried it yet, but I will when I get home tonight. I noticed before that "manual" was highlighted in Ryzen Master (even though I've never manually done anything to this CPU), but when I've tried clicking on either the "Auto" or "Precision Boost Overdrive" buttons, nothing happens (they are not interactable buttons). I also noticed near the bottom of the Ryzen Master page it says "Current Profile is Read Only", so I took that as an indication that it can't be changed.

    That said, I never considered the fact that these buttons might be non-interactable because I wasn't running Ryzen Master with Admin privileges. That kind of makes sense actually. I'll try running as Admin later today!
We love seeing what our customers build

Submit photos and a description of your PC to our build showcase

Submit Now
Looking for a little inspiration?

See other custom PC builds and get some ideas for what can be done

View Build Showcase


If You Can Dream it, We Can Build it.

Services starting at $149.99