Unable to POST With 5600x or 3600 Using B550 Tomahawk

Problem Description: TL;DR: Upgraded build not POSTing, only shows DRAM or CPU debug LEDs with no video output. Reverting back to old build doesn't POST either now. Tried combination of two new motherboards, two new CPUs, and two new kits of RAM with a previously used GPU and PSU.

Longer Version: Upgrading from a 6 year-old build, I ordered a 5600x, MSI MAG B550 Tomahawk, and the 32GB G.Skill RAM. I kept the GPU and PSU from the old build as they were working just fine for my needs. Built the new computer but it wouldn't POST. The motherboard's EZ Debug showed either the CPU or DRAM LEDs and there was no display on the monitor. I spent about 12 hours trying four different USB sticks with the latest three versions of the BIOS using the USB BIOS flashback feature, but the on-board red LED would just continuously blink forever until I shut it off (the longest I waited was about 5 hours while I slept).

Since the debug LED was on the DRAM label, I decided to grab some new RAM (the Crucial one listed above) to try that out. The issue still persisted so I got a second motherboard (same model) assuming the first one was not working. Still had the same issue. So I bought a 3600 assuming it was a BIOS version issue with the 5600x and hoping it would be able to boot with the 3600 and then I could update the BIOS. Yet again, the issue stayed the same (though the CPU LED was on for a while at first before it went to the DRAM LED).

Since the original build was working two days ago, I decided to plug that all back in for now. However, once I did that build wasn't working either. Instead of the debug LEDs, however, when I tried to boot it the fans on the GPU/PSU/CPU would just spin for half a second or so and then stop and then continue doing that until I shut it off.

Since it now doesn't work with a previous build that was 100% working two days ago, my assumption is that either the new motherboard damaged something or somehow the GPU and PSU (the only two components shared between all three attempted builds) have been damaged over this time. However, the PSU was never removed from the case except for about 20 minutes before this post when I was checking that the semi-module cables (8-pin CPU and PCIE power cables) were securely in it. As for the GPU, I only cleaned off the dust (using a q-tip and a microfiber rag) from the fans and the heatsink behind them. So after two full days of trying to debug and getting new hardware to test with, I'm about completely out of ideas on what the issue could be.

Troubleshooting: Here's a list of things I've tried so far:
  • USB BIOS flashback using all four USB drives I own with the three latest versions.
  • Resetting BIOS (grounding pins and removing CMOS battery)
  • Reseating one and two sticks of RAM for all four sticks owned in all four slots in both motherboards.
  • Reseating all components.
  • Verifying power connections (8-pin CPU, 24-pin ATX, 2x 8-pin PCIE).
  • Checked for bent pins on the CPUs.
  • Checked that CPU fan wasn't too tight.
  • Used two different motherboards (same model).
  • Used two different processors (3600 and 5600x).
  • Reverted back to the old build which now doesn't work.

Spec List:
CPU: Ryzen 5 3600 and Ryzen 5 5600x
Motherboard: MSI B550 MAG Tomahawk
GPU: Sapphire Radeon R9 290X 8 GB Tri-X
RAM: 32GB Crucial Ballistix 3200MHZ CL16 and 32GB G.Skill Ripjaws V 3600 CL16
PSU: Thermaltake Smart 850 W 80+ Bronze Certified Semi-modular

I'm really confused on what my next steps should be. I'm not sure if I've just somehow botched the building process each time I've tried or if I've been unlucky with the parts I have.


  • TSTDavey
    Hello @MegaCrapkin thanks for posting on the Microcenter Community forum. For the B550 and the Ryzen 5 5600x, did you update the bios with MSI USB software? To get the B550 and Ryzen 5 5600x, you may have to update the bios. You could bring it to the store for bios update for $30.
  • @TSTDavey , yes I did try to update the BIOS for the 5600x using the USB BIOS flashback option on the motherboard. However, like I mentioned, none of the four USBs drives I own using any of the three latest BIOS versions from MSI's website would successfully finish updating. That's why I tried the 3600 using the same motherboard (same model, but a second motherboard), but I still had the same issue.

    After making the post, I re-built the old build and took out the graphics card (the old build has integrated graphics) and tried booting. That one was successful, making me think the issue was the graphics card. So I picked out an XFX 5600xt, but I'm still running into the exact same issues. With the 3600 and B550 Tomahawk I'm getting the CPU debug LED and on the old build it will not fully turn on (CPU/PSU fans start for a second then stop and repeat that until I turn it off). With a new GPU too, I'm thinking the problem may then be the power supply as I can't think of anything else that would prevent a POST after trying two motherboards, two CPUs, two kits of RAM, and two graphics cards.
  • TSTDavey
    @MegaCrapkin You could try to reset the bios by removing the motherboard cmos battery for 60 seconds  then plug it back in. Then see if it post, you may have update the bios again because you're resetting it.  I'd recommend to bring your upgraded build to the store and have our tech guys there physically look at your build to determine the true root cause on why its not posting. At this point we're trying different things and given you different solutions to try without even physically seeing your upgraded build. Bring it to the store for a diagnostic.
  • What ended up being the problem? I’m having a very similar issue, but don’t live very close to a place I can get it checked. 
We love seeing what our customers build

Submit photos and a description of your PC to our build showcase

Submit Now
Looking for a little inspiration?

See other custom PC builds and get some ideas for what can be done

View Build Showcase


If You Can Dream it, We Can Build it.

Services starting at $149.99