Asus Prime Z390-A mother board stuck in BIOS


Hey All!

Am no stranger to building a PC - did one from scratch about 5 years ago - but recently wanted to upgrade my Asus motherboard and a newer Intel i5 CPU. New Asus Prime Z390-A and new Intel i5-9600KF from Micro Center Rockville with older Nvidia GTX 1050Ti and older G Skill RAM and Samsung SSD in M.2 socket. After install of above into my older Corsair case system would not even powerup - no LEDS on front etc. Took system to Geek Squad 3 times now and although system now powers up but only goes to BIOS and will not boot up....tried downloading to USB all the drivers and firmware for this board from Asus but BIOS gives failure notice trying to boot from the USB. Also BIOS will not open BIOS update using Ethernet Internet connection - says no connection. After 3rd Geek repair system was working - brought home and tried BIOS AI overclocking which produced a 44% overclock with blue screen failures. Also turned off Aura lighting in BIOS. Got stuck in BIOS again - took back to Geeks late yesterday.

Would appreciate suggestions as to what is going on??!!


  • TSTDavey
    Hello @breezer61 thanks for posting on the Microcenter Community Forum. You mention you are using an older Samsung SSD and after the upgrade,  the system goes into the bios but won't boot up presumably  into windows. I'm assuming the Samsung SSD has windows on it you are trying to boot into windows from the older SSD. If this is the case please confirm as you may have to try legacy mode under the bios boot options to see if it can boot to windows from the older drive. It may work it may not since the old samsung ssd is registered to your previous motherboard. Let us know if this is what is happening we may have some other suggestions.
  • StormSniper_
    Did you have an OS on it, or did it get erased? That is what happens a lot of the time. If so, then you might have to wipe your SSD, download WIN10 installation media on USB drive, put it, and power it on. If not, you system is out of date probably.
  • StormSniper_
    StormSniper_ ✭✭
    5 Likes First Comment Name Dropper
    edited December 2020
    Your RAM may be DDR3 instead of your motherboard that runs DDR4, and that is why. You need to upgrade your parts together. And also, you may have overclocked your RAM to a setting that is not too high, or not too low, but is not capable in your system, or not a Registered speed, but the speed has to be put. Basically, there are speeds like 3500 Mhz that are not supported by a CPU that can support some speeds, like 3600, 3200, 4100, etc. Your motherboard may not work because of that, and you have to Reset DMOS. Or, you should most likely return the MB. 
    (I don't know how to reset DMOS)
We love seeing what our customers build

Submit photos and a description of your PC to our build showcase

Submit Now
Looking for a little inspiration?

See other custom PC builds and get some ideas for what can be done

View Build Showcase


If You Can Dream it, We Can Build it.

Services starting at $149.99