WD Blue 1TB HDD (WD10EZEX) isn't recognized by Windows 7 (in file explorer or diskmgmt.msc)

Yes, I know I need to upgrade to Windows 10 (and look into an SSD as well) but first things first. 
On booting, I get this message:

Copyright (c) 2003-2008 Intel Corporation                                                                                           18
*** This version supports only Hard Disk and CDROM drives ***
Please wait. This will take a few seconds.
Controller Bus#00, Device#1F, Function#02: 06 Ports, 02 Devices
Port-00: Hard Disk, WDC WD10EZEX-00BNA500
Port-01: No device detected
Port-05: No device detected
AHCI BIOS Installed

As you can see Port 00 is my boot  WD Blue 1TB HDD (same model as new drive) that I've had for a couple of years without issue.

Notice the 02 Devices.  If I unplug my new device it shows 01 Devices.  Does that mean anything? This would seem like a good thing.

I've swapped the SATA cables and power supply between the these two drives with no difference (except my boot disk points to Port-01) to eliminate those issues. 

Windows reports that my driver for the current boot drive is up to date.  Although maybe not for the new drive...?

I have a GIGABYTE GA-Z68-UD3H-B3 motherboard running an Award BIOS version F12 dated 03/20/2012. The only update for the BIOS is to upgrade to UEFI which I haven't had the need to or want to - given my machine has been stable for years. I want to just keep my current bootable Win 7  WD Blue as an external drive via USB (or backup boot drive)  and the new one to be used for a new clean install of windows 10. I just want to see the new drive before proceeding. I tried to connect the new drive via a USB to SATA drive adapter without any luck either. I can tell you that the new drive does spin upon booting and stays spinning until just about the time I run diskmgmt.msc when it stops and disk management reports nothing about this new drive.

I went through all of this with Western Digital tech support via chat, and they suggested I just return the drive. 
I don't know if the tech was just searching the internet for a fix or management has decided it's in everybody's best interest to just return the $40 retail item.



  • PowerSpec_MikeW
    PowerSpec_MikeW PowerSpec Engineer
    5 Insightfuls First Anniversary First Comment 5 Awesomes
    Greetings @chris_g8

    Two questions for you to start. What SATA ports on the board have you tried and what storage controller mode are you set to in the BIOS?
  • chris_g8
    I tried the 6 ports and all the same. The disk spins for a spell then stops. No detection inside windows.  The device count is 2. The screen will pause on port detection on the port I was connected to, but would still return no detection.
    I performed the Load Fail-Safe Defaults. This set the PCH SATA Control Mode to IDE.  This wreaked havoc until I reset to ACHI.
    I'll probably get yet another drive and cable and a better quality USB to SATA drive adapter when the ice melts (metro Kansas City got hit with some sleet/ice mess). 
    Thanks for taking the time to respond. 
    All the best,
  • chris_g8
    I exchanged the drive in question with another one of the same make and model from Micro Center and had no problems.   I owe Western Digital Technical Support an apology for they thought that the drive was probably defective and they were right. 
  • Ian
    Unfortunately defective products can happen, I am glad to hear a swap out got you up and running.
We love seeing what our customers build

Submit photos and a description of your PC to our build showcase

Submit Now
Looking for a little inspiration?

See other custom PC builds and get some ideas for what can be done

View Build Showcase


If You Can Dream it, We Can Build it.

Services starting at $149.99