Have to unplug and plug in keyboard every time to use it. — Micro Center

Have to unplug and plug in keyboard every time to use it.

I bought a new Powerspec G163 gaming computer from microcenter a few weeks ago and I have been having trouble with the keyboard which is plugged into two USB ports in the back of the computer. Every time after the computer has been asleep, the keyboard does not respond until I physically unplug it and plug it back in. Then it works just fine. (Keyboard is Corsair K70 MK.2) Can anyone help me with why this might be happening? I didn't build this computer and I'm not extremely tech savvy so I'm not sure if the problem lies in the keyboard or the computer itself. TIA. 

Comments

  • Hello, @Bridget Welcome to the community! It sounds like your computer is putting your keyboard to sleep and not letting it wake. You have to disable the USB port from turning off on sleep mode:

    1. Press the Windows key + X to open the setting menu. Select Device Manager or press M to open the Device Manager Window.

    2. When the Device Manager window opens, expand the Universal Serial Bus controllers branch, then right-click the USB Root Hub (May Say your device name) device and select Properties.

    3. Click the Power Management tab. If you want USB ports to keep supplying power in sleep mode, just uncheck “Allow the computer to turn off this device to save power“.

    Repeat steps 2 and 3 for all of the USB Root Hubs on the computer.

    Then test it.

    Let us know if this works for you!

  • Greetings @Bridget

    I noticed looking at the keyboard specs, that this keyboard has a USB passthrough. This would make it a more unique example and is likely related to why you're encountering this issue. With the keyboard acting additionally as a hub. I believe this keyboard has dual USB to facilitate this. Do you have both connected? If so, can you test with just the cable for the keyboard connected, and leave the passthrough disconnected?

    Another thing to test would be disabling hibernation, to verify the issue is only occurring in the S4 state, and not S3.
  • @LandShark that worked! thank you so much and thank you @TSMikeW for the response as well!
  • IanIan admin
    Bridget said:
    @LandShark that worked! thank you so much and thank you @TSMikeW for the response as well!
    I am glad to hear that worked, please let us know if you have any other questions! 
Sign In or Register to comment.