Problems with G434 Asrock Phantom Gaming z390 4s/ac.

edited April 2023 in PowerSpec
I feel like my PC needs a Bios Flash. I have issues that the service department has not been able to resolve. I have a constant POST Solid LED DRAM "red" when resuming from sleep only, the only work around is to put it into Hibernation only or restart. My CPU seems to be undervolting in the BIOS. I have frequent Boot loops requiring a Hard restart. I have a false positive detection of MIC if front panel detection is toggled off. I show Bluetooth adapter as Disconnected Both in System Properties and The system info screen for adapters in Windows even when I have Live connections. I have tried entering different sleeps. 
The problem: Asrock did not Manufacture this board it is an OEM hence the "AC" Variant. Microcenter does not possess or support in their library the current Bios. As Such since the Board is not made By Asrock, Asrock Does not Support the BIOS. I have done some research as the team at my local Microcenter has been unable to resolve these same issues on two service appointments.  
I have found that with some research some indication that an FTP site "iBUYPOWER" Does have the current Bios. vs 1.21a
and for informational and opinion I will provide links to this Motherboard.
Here is the link to the Site and the File and the discussion.

Please help, Thank you.


  • TSTDavey
    Hello @Greg_D4791 thanks for posting on the Microcenter Community Forum. The G434 should have a Asrock manufactured motherboard. If your system can still boot into windows, follow the instructions and video below to validate the motherboard that is inside your system. Let us know if it is an Asrock board per the CMD results.
    It sounds like there could be an issue or defect with the motherboard. A bios update is a troubleshooting option to see if it fixes your issue, but it could be the board. You should have a warranty on the system if its within a year from purchase.
    Use the links below to entering commands into Command Prompt to find out what motherboard is actually installed.

    1. Go to Search, type cmd, and open Command Prompt.
    2. In the Command Prompt, enter the following command and press Enter: wmic baseboard get product,Manufacturer,version,serialnumber

  • Greg_D4791
    Manufacturer: Asrock, Model: Z390 Phantom Gaming 4s/ac,   s/n m80-c9019000737. Problem That I am hearing from Asrock is that because it is an "ac" variant, they do not support BIOS for it, in fact the Motherboard is not on their site at all. After trying to communicate that with Asrock and Microcenter they say the board has no BIOS either in the Microcenter Index, Nor the Asrock website. I am guessing this is the OEM factor. Asrock specifically stated to not use any BIOS Flash from their website for this board.
    I am in fact trouble shooting. According to Microcenter, Powerspec  AsRock OEM Uses a CUSTOM Bios, that includes splash screens etc. I found a BIOS for the board but I do not like to mess with BIOS unless I feel like something is wrong. I.E. The above issues.

    Thank you for the response.

  • Greg_D4791
    UPDATE BIOS REVISION 1.21a Corrected EVERY problem/issue I had.
    Thanks. PM me if you want the file.
  • jgerondale2

    is the 1.21a the newest bios version for the 4s/ac? I found on reddit someone posted a 1.20. I am looking to update bios and like you said its nowhere on asrocks website and microcenters.

  • James301
    James301 ✭✭
    Name Dropper First Anniversary First Comment
    edited April 2023

    I tried both the 1.20 and the 1.21a, and a 3rd 1.3 that I found. both the 1.2x boot up with ASROCK in the logo screen, but the 1.3 version boots up with 'powerSpec' in the logo screen. My question is: in the version that you are using can you trun off the XMP2.0, I have found that it will eaither be set to auto or profile1.

    What version are you using and can you turn it off?

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

We love seeing what our customers build

Submit photos and a description of your PC to our build showcase

Submit Now
Looking for a little inspiration?

See other custom PC builds and get some ideas for what can be done

View Build Showcase


If You Can Dream it, We Can Build it.

Services starting at $149.99