PowerSpec G436 - Memory Upgrade Fail


I recently purchased this power spec PC because the video cards were hard to come by and it already had one in it. I have upgraded the memory in it from Forza 3200MHZ CL16 32GB to this 3600MHZ GSKILL CL14 64GB Ram. 


I enabled the XMP Profile in the BIOS and the machine was running fine for 2 days of gaming pretty heavy and then in the middle of a game last night my system crashed and when it booted back up I got a message that said Memory Overclock Fail. I disabled the XMP profile and now the ram is running at its stock speed 2666mhz and the PC Boots up fine. When I get home today after work I will probably try to manually input the Memory timings/frequency/voltage in the BIOS instead of using XMP Profile. I'm trying to figure out if I need a different motherboard that can handle this ram or if you might have any suggestions on what I could do to fix this? I haven't seen anywhere where you can update the BIOS on MSI's Site, I dont think this is a board you can buy over the shelf and something power spec probably bought in Bulk straight from MSI. Thanks for your help.


  • JS_MC
    JS_MC admin
    First Anniversary 5 Up Votes 5 Awesomes First Answer
    edited January 2021
    Hello @jhamms17 Welcome to the community!
    If manual timings don't work, I'd recommend adding RAM in groups. You're correct about this board being an OEM board that's not available over the shelf. However, we should be able to get this working, as it was stable for a time before the crash.
    I might suggest adding two sticks at a time, and once you've enabled the XMP for those two, adding the second two sticks.
    Let me know if I can help with this process!
  • jhamms17
    Thank you so much for your response, id love to get this working without buying a new motherboard, I was going to wait until the 11th gen intels came out to upgrade MB lol. Ive already tried adding them in Groups with XMP Disabled, with XMP disabled it boots fine with 2 or 4 sticks, now as soon as I restart and go into BIOs and enable XMP I get the memory overclock error. Its strange to me it was stable for two days and now its not. I alternated with the groups of only 2 sticks to insure I didnt just have a bad stick, both groups of sticks gave me the  same error once XMP was enabled. 
  • JS_MC
    I'd recommend downclocking the memory in steps until you find a speed/voltage that is stable or stepping it up from where it is stable until you find where it fails.
    Do you have any overclock set on the CPU or GPU?
  • jhamms17
    Thank you , that’s a great recommendation. I do not have any overclock done on gpu or cpu. 
  • jhamms17
    I’m curious to why it used to let me boot in XMP profile , ever since it crashed in game it has not let me boot with xmp profile enabled.
We love seeing what our customers build

Submit photos and a description of your PC to our build showcase

Submit Now
Looking for a little inspiration?

See other custom PC builds and get some ideas for what can be done

View Build Showcase


If You Can Dream it, We Can Build it.

Services starting at $149.99