PowerSpec G436 No Video Output after Intel RST Installation


Hello! I've just installed (2) 8TB 3.5" Seagate HDDs into the open bays at the bottom of my new PowerSpec G436. On my last computer I had an Intel RST software RAID configured and it worked great. I was attempting to set up the same configuration this computer.

During installation of the Intel RST driver and software, I initially chose to keep the SATA controller in AHCI mode. After the successful installation and reboot, I noticed the option create a RAID in the software was greyed out.

I then ran the Intel RST installation again, this time opting to switch the SATA controller from AHCI to RST Premium. It warned that the computer would need to reboot into Safe Mode to make the SATA controller mode change and then would boot back into the OS normally to complete the Intel RST installation.

My Windows OS is installed on the M.2_1 slot, so I assumed it wouldn't be effected by the SATA controller change.

At this point, the computer rebooted but no longer displays a video output through either the 4 ports on the installed RTX 3070 (1x HDMI, 3x Display) or the 2 ports on the MSI motherboard (1x HDMI, 1x Display).

It appears to boot (all LEDs and case fans light up), but I can't seem to get video out of this computer anymore.

Any assistance on what I can try next to at least get video out to see what could be happening would greatly appreciated. Thanks!


  • czarship

    I should also note that while the computer appears to boot, I can't ping it from other devices on the network, so I don't believe it's making it into the OS.

  • czarship

    Just noticed that the "DRAM" LED is lit on the motherboard near the "EZ Debug LED" section of the board.

  • czarship

    I've resolved my problem! I'm not exactly sure what the Intel RST installation did, but it looks like it made a change to the BIOS somehow.

    After finding the CMOS battery hidden behind the graphics card, I removed it for a few minutes and reseated it. This finally produced a POST screen to my monitor. I booted to the OS and noticed the "Create RAID Volume" option in the "Intel Optane Memory and Storage Management" was still greyed out.

    I then booted back into the BIOS and changed the SATA mode from AHCI to RAID in "Advanced Settings". Thankfully, the OS booted without issue and I was then able to create a software RAID in the Intel software.

    In summary, I'm still not exactly sure what the Intel RST installer did, but it looked like it was trying to boot into safe mode to do some changes to the registry to support the AHCI to RAID change. Since this didn't appear to be working, I opted to manually change the SATA operation mode form AHCI to RAID in the BIOS myself. Afterwards the computer booted without issue and let me configure the software RAID.

    I was doing some research and noted others mentioning registry edits to make drivers compatible after the SATA mode switch, however I have yet to notice any issues with the OS or its installed drivers/software. Perhaps compatibility has improved enough recently to render this a non-issue.

    Anyway, I wanted to voice my issue, thought process, and eventual conclusion to my issue to hopeful support others in case they run into a similar situation.

  • Ian

    Hello, sorry for the delay in response. I am glad to see you got the issue fixed and there is for sure some good information here.

  • czarship

    Hey @Ian no worries, thanks for your reply! I honestly didn't expect a response on the weekend anyway, but usually find it helpful to step back and talk out the issue or bounce ideas around when I'm stuck on something.

    On a side note, I am loving this build, it's running any VR game I'm throwing at it wonderfully.

    One thing that may help others is an issue I had mounting the 3.5" drives for the RAID:

    After installing my 3.5" drives to the 2 available mounting bays at the bottom of my PowerSpec G436, I noticed they protruded out a bit so that after they were cabled, it wasn't possible to put the right side door back on. So I unscrewed the 4 screws on the bottom of the case near it's front face which allowed me to fully remove the 2-drive mounting bay out of the right side of the case and then reverse it. After securing the bay again, but facing it in the opposite direction (drives slide in on the right side of the case instead of the left now), the 3.5" drives now slide further into the case, allowing for a lot more space to cable them and close the side door.

    I'm sure this is an easy thing to get reversed during the build process, especially without 3.5" drives to help visualize the space. I was very happy to find this bay for bulkier drives included in the case, however, as it helped me fit more storage space in.

    Best wishes and have a great weekend!

We love seeing what our customers build

Submit photos and a description of your PC to our build showcase

Submit Now
Looking for a little inspiration?

See other custom PC builds and get some ideas for what can be done

View Build Showcase


If You Can Dream it, We Can Build it.

Services starting at $149.99