Powerspec G507 - Monitor randomly says "No Signal" causing PC reboot.

edited May 2021 in General Discussion

Hello! I have purchased a Powerspec G507 back in December 2020 and have been loving it ever since. About 8 days ago, I decided to upgrade my ram from 2x8gb G.Skill Ripjaws DDR43200 to the same brand G.Skill Ripjaws DDR4-3200, except it was 2x16gb instead of 2x8gb. After I installed the new RAM, every so often (seemingly random) the monitor would go black and display "No Signal" yet the keyboard, mouse, and computer itself would stay on. The only way to remedy this would be to hard-restart the computer. After a couple of minutes or up to an hour, it would happen again.

I decided to try putting the old 2x8gb ram sticks back in and that seemingly fixed it for 2 days until it started happening again. This has caused me to try uninstalling the GPU drivers with DDU in safe-mode and reinstalling them. Problem still persists! I have tried older versions of GPU Drivers, and even the latest version to no avail. I have also reseated my GPU, all the power cables inside the computer, and the ram itself. I have tried uninstalling and reinstalling the latest version of every driver possible for every piece of hardware on my PC, still to no avail. I have also tried downloading the AMD GPU drivers by themselves with Device Manager and NOT downloading the Radeon Adrenaline software. This does not work either. Before I started trying this, I would download the Radeon Software with the drivers and upon reboot of the computer after monitor crash, the AMD Drivers would not be detected at all, causing me to redownload them. Now that I install an older version of the drivers by themselves with device manager, they are always detected upon reboot but I still have Monitor "No Display" crashing issues. This is all seemingly random too. It can happen while at home screen idling, while playing games, basically at any random time. It's also hard to replicate the issue because of the randomness.

I have thought about updating the BIOS but did not see the point yet.

After rebooting, i'll check the Windows Event Viewer and Reliability history. Live Kernel 141 errors keep showing up with a error code Bucket ID: LKD_0x141_Tdr:6_IMAGE_amdkmdag.sys

Specs are:

Mobo - ASrock b450m/ac

CPU - Ryzen 5 3600

GPU - ASrock RX 5700 challenger

PSU 600 watt 80+ bronze


  • TS_JosephF

    Hello @travisC

    Have you tried performing a mem test on both the 8 GB and 16 GB modules? Have you tried installing them in the opposite slots to see if that has an impact?

    From what I could find about that error code, it is pointing to your GPU or the GPU driver that is causing this. Which you have been quite thorough in troubleshooting. Are you able to boot to safe mode and see if the system would crash? I know you mentioned it is hard to recreate since it's just random but this could help determine if it is the GPU driver causing the crash.

    Did you happen to make any other changes to the PC? Even install a Windows update?

    I see the PowerSpec is still under warranty too. So if need be, you could always bring it in for us to complete diagnostics.

We love seeing what our customers build

Submit photos and a description of your PC to our build showcase

Submit Now
Looking for a little inspiration?

See other custom PC builds and get some ideas for what can be done

View Build Showcase


If You Can Dream it, We Can Build it.

Services starting at $149.99