Internet Throttling - Cabled Connection


Hello....Need some networking insight. A user in my office was provided the following PC as their workstation.

We are using a Comcast Gigabit Internet connection at the office, and we redid our Voice/Data cabling throughout the entire office. All PC's are now hardwired (cabled) and the standard Dell workstations are getting between 600 - 900 mbps on download. However, the user on the PowerSpec PC is only getting 90mbps and appears throttled. I have gone into their network adapter settings and we have tried changing the Speed/Duplex from Auto to 2.5Gbps "Full", and vice versa. We then run a speed test immediately after change and they get 600-700mbps download for at least one test. Immediately following that, all follow up speed tests go back down to 90-95mbps. It is clear the PC can get Gigabit cabled speeds, but something is throttling it and I can't figure it out. He has removed all the ASUS gaming bloatware, and other applications. Is this a Network Card driver issue? I just can't sort it out to make it stop throttling to 100mbps (even though this is ample for the average user). Just looking to solve the problem...Thanks!!


  • PowerSpec_MichaelB
    PowerSpec_MichaelB ✭✭✭✭✭
    First Answer 5 Insightfuls First Comment 5 Awesomes
    edited October 2021

    Welcome to the forum, @SwiftyRox. This is definitely an odd one. The PowerSpec B747 uses a Realtek RTL8111H RTL8125 2.5G LAN adapter and we can try ruling out the driver itself by downloading the latest driver ASUS has listed for that board:

    The fact that you can momentarily achieve 600-700Mbps before it falls back down to 90Mbps makes me wonder if something managed on the network itself is set to throttle this systems MAC specifically (if configured to limit network bandwidth through QoS via MAC/Sticky MAC). Are you the administrator of the network in your office, and would you be able to confirm if such a QoS is implemented throughout the office to control overall network bandwidth? Would definitely be worth looking into.

    If you didn't have to do anything fancy with the Dell systems during their setups (and are using the same Ethernet cable), I would almost be left to believe something is up with the ethernet controller itself. @TSMikeW , thoughts?

  • PowerSpec_MikeW
    PowerSpec_MikeW PowerSpec Engineer
    5 Insightfuls First Anniversary First Comment 5 Awesomes


    Make sure you got rid of the ASUS GameFirst app if it was installed. We don't install any of the ASUS software by default on these systems. This program in particular has network optimization functions that will skew your network speed test results.

    To verify, the connection is auto negotiating to 2.5Gbps or 1.0 Gbps? If the latter, try to set Speed/Duplex to 1.0Gbps full duplex and test again.

  • SwiftyRox

    Hello...In response to this oddity...I'll explain what the resolution was as it's now solved!!

    The nutshell: It was a cable issue!!

    I decided to use some old-school troubleshooting steps to rule things out and work my way back to the computer to see if it was a driver, software, or hardware issue with the PC. Yesterday, I had already tried (2) Cat5e cable swaps to see if it was the cable (Needed that mentioned for context)

    I still cannot account for the singular successful gigabit speed test results as the same adapter settings changes today did not get those same results. It just stayed at 100mpbs on the download speeds. There was a moment where it switched from the LAN to Wireless as I was making network adapter changes, but no wireless connection that I know of will every get 800/900 down...maybe 300/400.... I brought in an old laptop of mine that has a Gigabit NIC connection to rule out the wiring at the wall port and/or the cable from the port to the physical PC. I grabbed a different Cat5e cable than the one that was connected to the PowerSpec PC (Mind you, I had already tried 2 cable swaps yesterday). I connected the "new" Cat5e cable from the wall to my laptop, and checked the adapter settings....1.0 Gbps!! So I could rule out the wall port and the cable "I was using"....

    So, with that in mind, I decided to try that same cable from the wall to the PowerSpec...plugged it in, and BOOM....The network adapter started registering a 1.0 Gbps connection!! Unbelievable!! So we went ahead and ran consecutive speed tests and all registered 700-900 mbps download. Issue Solved!! So now it's a matter of getting rid of all of the subpar Cat5e cables in the building so I no longer have this issue with any other PC that will be hardwired!!

    Thanks for your response on this one. I literally had tried everything including disabling AutoTuning in the netsh command. About the only thing I had not done yet was uninstall the Realtek driver and reinstall it. I had already tried updating it and that did not solve the end....IT WAS A FREAKIN' CABLE!! :)

We love seeing what our customers build

Submit photos and a description of your PC to our build showcase

Submit Now
Looking for a little inspiration?

See other custom PC builds and get some ideas for what can be done

View Build Showcase


If You Can Dream it, We Can Build it.

Services starting at $149.99