Microphones not working on new PowerSpec PC (driver issue?)


Hey All - I just got a PowerSpec G229 at Microcenter a couple weeks ago. It seems great except that microphones are not working most of the time. The issue is very random/inconsistent, aside from it happening regardless of which microphone I connect. On rare occasion it will work fine. Many times if I test the microphone you can see the little equalizer-type bars going up & down, but if you actually try to record anything the resulting video will have no audio. Sometimes, I can successfully record something with the Voice Recorder app but not Geforce Experience; other times I can't record at all. The listing for the microphone in Device Manager usually will have the yellow triangle icon indicating there's a problem; sometimes not. I've tried uninstalling & re-installing the drivers from Windows and I've tried downloading & installing the realtek audio drivers manually. I saw somewhere someone said the realtek and nvidia drivers can mess w/ each other and that the nvidia ones aren't necessary, but when I disabled them I didn't have any audio at all.

Just wondering if anyone has ideas here before I take the PC in to have them look at it & possibly exchange. Thanks for any info!



We love seeing what our customers build

Submit photos and a description of your PC to our build showcase

Submit Now
Looking for a little inspiration?

See other custom PC builds and get some ideas for what can be done

View Build Showcase


If You Can Dream it, We Can Build it.

Services starting at $149.99