New ASUS B450M-A II not displaying


My current set up is a Ryzen 5 5600G with an ASUS B450M-A II, and Radeon R9 290. I'm not getting any display currently.

(New member so I can't post links, sorry.) This is the bundle I bought at Micro Center yesterday AMD Ryzen 5 5600X, ASUS Prime B450M-A II, CPU / Motherboard Combo

I bought this bundle yesterday. Looking at PCPartPicker, they have it listed with the following warning.

I checked the documentation that came with the mobo and this lines up. I tried updating it, and still no display. I think there might be an issue with my graphics card causing this, but I can't be sure. All fans are on and the PC seems to boot. Not really sure where to go from here. What do you suggest?


We love seeing what our customers build

Submit photos and a description of your PC to our build showcase

Submit Now
Looking for a little inspiration?

See other custom PC builds and get some ideas for what can be done

View Build Showcase


If You Can Dream it, We Can Build it.

Services starting at $149.99