i just finished building my pc and now it doesn't even turn on. — Micro Center

i just finished building my pc and now it doesn't even turn on.

the only thing i see getting some power is just the motherboard cus the light turns on.    can someone help me? do i need more power? or do i have connections wrong.  or what else can it be    
    cpu - amd ryzen 7 3800x
 graphics card - evga geforce rtx 2070 super black.
 memory- tridentz G skil 16gb 2 x 8gb
 cpu cooler- kraken x62 280mm liuid cooler.
 SDD- samsung 970 evo 1tb nvme M.2 
motherboard- Asus prime x570 
power supply - evga supernova gold 750g+.                                                                    ion                                                                                                                                                                                            
 

Comments

  • Hello @eddie! Welcome to the Community. 

    I realize you made this post a couple days ago so you may have already gotten your answer, but from the pictures you posted it looks like you just forgot to plug in the 8-pin CPU power connector on the top left corner of your motherboard. 

    We also have a guide here that will walk you through other troubleshooting steps if you have more issues getting the system to boot. 
  • Hi @eddie!
    I'm new to the community so I apologize for the late comment. If it isn't posting, but it looks like it's turning on, it could be the g.skill memory. My rig wouldn't post at first. I have a Ryzen 5 3600 with the 2070 super GPU. The Micro Center tech team checked with other memory and it posted. They let me swap the RAM with Ballistix.  
  • I have highlighted the area Tony has referred to. Missing these power connectors are for sure the issue you are experiencing. 
Sign In or Register to comment.