New PowerSpec G434 freezing while playing games — Micro Center

New PowerSpec G434 freezing while playing games

Have a new PowerSpec G434, I have not updated it to overclock or done anything custom to it.  It freezes after a couple minutes of playing any games.  When it freezes nothing works, can't control+alt+delete or anything.   Brand new computer, thinking about taking it back. 

Comments

  • TSIanLTSIanL admin
    Greetings. The first thing we would suggest if it is only freezing when playing games is to try a roll back or clean install of your video card drivers. Here is our guide on how to do that: https://community.microcenter.com/discussion/2858/tech-article-how-to-roll-back-or-clean-install-video-card-drivers-in-windows-10 
  • Thanks for the comment. I did a re-install of the video card drives, but didn't totally clean them out first (still had the problem after re-install).  So I decided to check task manager while games are running.  What is happening is if the game is set to 'Optimized' in GeForce Experience settings the GPU runs at 100%.  This makes the system crash.  I am able to turn down some of the 3D settings in the NVIDIA control panel (tune them down from the out of the box settings), which causes the GPU to run at about 50% and the system runs fine.   So I guess my next question is, if i clean out the video drivers and re-install can the system run with GPU at 100%?  I was disappointed I had to tune down the graphics.
  • NWSide77 said:
    Thanks for the comment. I did a re-install of the video card drives, but didn't totally clean them out first (still had the problem after re-install).  So I decided to check task manager while games are running.  What is happening is if the game is set to 'Optimized' in GeForce Experience settings the GPU runs at 100%.  This makes the system crash.  I am able to turn down some of the 3D settings in the NVIDIA control panel (tune them down from the out of the box settings), which causes the GPU to run at about 50% and the system runs fine.   So I guess my next question is, if i clean out the video drivers and re-install can the system run with GPU at 100%?  I was disappointed I had to tune down the graphics.
    You shouldn't have to tune down the graphics whatsoever. If you reinstall the graphics drivers and still have to compromise on graphical settings to avoid a crash, something is fundamentally wrong. Do you feel comfortable enabling an On Screen Display to monitor your performance while gaming? I am curious to see if the card is reaching high temperatures and is throttling, or if something else at fault.

    I have a quick guide here that explains how to setup an OSD using MSI Afterburner: https://community.microcenter.com/discussion/3077/guide-how-to-install-enable-on-screen-display-in-msi-afterburner-rtss#latest. Make sure you read the disclaimer, I'd recommend testing on a single player game to be safe as not all online games play nicely with MSI Afterburner/RTSS.

    I would specifically monitor CPU temperature, GPU temperature, CPU usage, GPU usage and memory usage. If everything looks normal during the crash, we know it's not an issue with throttling or usage, but rather something else. From there, we can do some additional troubleshooting to narrow down the culprit.
  • OK I ran it. These are the numbers at time of crash

    CPU Temp: 42
    GPU Temp:72
    CPU Usage: 15%
    GPU Usage: 100%
    Memory Usage: 15%


  • NWSide77 said:
    OK I ran it. These are the numbers at time of crash

    CPU Temp: 42
    GPU Temp:72
    CPU Usage: 15%
    GPU Usage: 100%
    Memory Usage: 15%


    All of that looks completely normal. You will want GPU usage to be 100%, this means nothing is bottlenecking your graphics card. The temperatures are well below the safe limitations, which means you should even be turbo boosting during this time without an issue. 

    This may sound a little weird, but can you try disabling the memory XMP profile in your motherboard's BIOS? Here are some instructions on how to do so:
    Step 1: Boot into your motherboard BIOS by restarting the system and tapping F2 or DEL.
    Step 2: Press F6 to access the Advanced Options.
    Step 3: Navigate to the "OC Tweaker" menu using the arrow keys or your mouse, and select "DRAM Configuration".
    Step 4: Locate the "Load XMP Setting" option and change this to Auto or Default.
    Step 5: Using the arrow keys, navigate to the Exit tab on the top right corner of the BIOS. Save and exit.

    Once finished, go back to playing your games as you normally would, and let me know if it crashes. I am curious to see if the motherboard is training your memory timings incorrectly when the XMP is loaded.
  • Still crashes in the exact same way
  • OK so i think the problem was the BIOS settings that come with the computer.  I have been following  a reddit thread on this problem:
    https://www.reddit.com/r/techsupport/comments/eint7b/new_gaming_pc_freezes_within_ten_minutes_of/

    Here is the text from the thread (seems like the updated bios fixed the problem for me)

    "Update: MicroCenter support just sent me an updated BIOS, and it seems to have fixed the instability... 2 hours without crashes, even with RAM at 3600 MHz.

    Here is the BIOS update: https://microcenter.zendesk.com/attachments/token/apOvh1Z60vI3U4OtU5gkgJ8vJ/?name=Z39G4SA1.30A

    You have to put it onto a USB drive and use the Instant Flash tool in the UEFI to enable it. Then you can re-enable the XMP profile for the RAM and set it back."




  • NWSide77 said:
    OK so i think the problem was the BIOS settings that come with the computer.  I have been following  a reddit thread on this problem:
    https://www.reddit.com/r/techsupport/comments/eint7b/new_gaming_pc_freezes_within_ten_minutes_of/

    Here is the text from the thread (seems like the updated bios fixed the problem for me)

    "Update: MicroCenter support just sent me an updated BIOS, and it seems to have fixed the instability... 2 hours without crashes, even with RAM at 3600 MHz.

    Here is the BIOS update: https://microcenter.zendesk.com/attachments/token/apOvh1Z60vI3U4OtU5gkgJ8vJ/?name=Z39G4SA1.30A

    You have to put it onto a USB drive and use the Instant Flash tool in the UEFI to enable it. Then you can re-enable the XMP profile for the RAM and set it back."




    Ah, sounds like you may have been on an older BIOS version, likely 1.10. This makes sense, as 1.30 improved some of the memory timing training. Hopefully your system remains stable. If you have any issues whatsoever, feel free to reach out, we will do what we can to assist. Thank you for sharing the solution for others that may have the same issue.
  • Just froze again.  Returning it tomorrow.  I'm done with this PC. 
Sign In or Register to comment.