AsrPolychrome installation problem

After resetting my o/s and losing all of my apps, I am trying to reinstall the AS Rock LED app to control the fan light color. 

I downloaded the Motherboard + RGB Control software from

I ran the Setup file: This PC->Downloads->MultiFrame_1_1_1_12->Setup

Then I went to c->drivers->PolychromeRGB->AsrPolychromeRGBSetup(v1.0.42) and double clicked on that.

After that installed, I tried to run it at This PC->Windows (c:)->Program; Files (x86)->ASRock Utility->ASRRGBLED->Bin->ASrPolychromeRGB

I get the error: This utility is not for this platform!. The upper left corner of the error dialog shows "Error 0xFFFC". When I select "OK" to dismiss the dialog, I see another error dialog that says "Access violation at address 00410E81 in module 'AsrPolychromeRGB.exe'. Read of address 00000000.

Am I having these problems because the Motherboard+RGB Control link at the Powerspec G356 Driver Downloads & Updates / Windows 10 is pointing to the wrong file? Here is the link:

Did I miss some kind of installation step?

Best Answers

We love seeing what our customers build

Submit photos and a description of your PC to our build showcase

Submit Now
Looking for a little inspiration?

See other custom PC builds and get some ideas for what can be done

View Build Showcase


If You Can Dream it, We Can Build it.

Services starting at $149.99