PC won't boot all 4 RAMs — Micro Center

PC won't boot all 4 RAMs

Hi everyone! Trying to figure out my RAM issue and this is my first build.

TLDR; 2 sets of rams. Same model. Same brand. Set A is Aug 2020. Set B is replacement pair, Apr 2021. Each ram stick and each slot works perfectly. It boots only in pairs, but not all 4 at once.


Let me know if you need more details:

AMD Ryzen 9 3950X Matisse 3.5GHz 16-Core AM4 Boxed Processor

ASUS B550-F ROG Strix Gaming (WiFi) AMD AM4 ATX Motherboard

2x G.Skill Ripjaws V 32GB (2 x 16GB) DDR4-3200 PC4-25600 CL16 Dual Channel Desktop Memory Kit F4-3200C16D-32G - Black

I had a pair of faulty RAM sticks that I had RMA-ed and replaced. For some strange reason, the new pair will not boot when all 4 slots are in. I tested each pair in different slots and they work perfectly. So I'm still stuck at 32GB instead of my usual 64GB RAM for work.

Both pairs are the same brand, same product number so I'm not sure what's going on. It was a simple replacement. My next step is contacting G. SKill support but curious what everyone else thinks?

Thanks!

Answers

  • IanIan admin

    Greetings. The best way to get a better idea on the issue would to be to try each stick of RAM one at a time in each RAM slot, and try to boot the PC, to see if there is perhaps a bad stick or a bad RAM slot.

  • cdotlucdotlu
    edited April 26

    thanks @Ian, all slots work perfectly and each ram stick is fine.

    the weird issue is... when I insert all 4 at once - it won't boot. but it can boot in pairs.

    i originally had 4 at once before until I found a faulty RAM stick. does this have something do to with the BIOs? i never touched anything in there but few folks are telling me to enable XMP or enable DOCP. I'm not sure what that means?

  • IanIan admin

    Try restoring to BIOS to default / default optimized settings and then try the 4 sticks again. Here is how to do that: https://www.asus.com/support/FAQ/1039491/


    XMP / DOCP is a way to optimize / overclock RAM timings in your BIOS. ASUS has a guide for that here: https://www.asus.com/support/FAQ/1042256/

  • thank you @Ian! i will try this out and report back.

    I also called g.skill and didn't expect them to pick up so quick. they said the manufacture dates might be interfering with the new replacement. my current RAM sticks are aug 2020 and my new ones are apr 2021. do you think that's possible too? that sounds so weird to me.

  • cdotlucdotlu
    edited April 26

    thanks again for the help @Ian. it did not work and I submitted another RMA ticket to g skill.

    i originally had 2 sets from aug 2020 that I bought at micro center. i had 1 set replaced because I kept getting bsod.

    g skill support claims 2020 set might not work with my new 2021 replacement set. depending on the time it was manufactured, the new set has new chips inside. it all sounds odd to me. they both the same brand, same product number, both 2x 16gb.


  • @cdotlu just chiming in. I may have missed it, but have you tried putting 1 2020 ram stick into the first RAM slot closest to the CPU, just ONE stick only; and see if it boots.

    If it boots, then turn it off and put a 2021 RAM stick in the same slot (1st RAM slot closest to the CPU). One stick only.

    If it boots with the 2021 stick in the first RAM slot, turn it off.

    Keep the 2021 stick where it is and put a 2020 ram stick in the 2nd RAM slot that's right next to the 2021 RAM stick.

    You should have 2021 stick in slot 1 and 2020 stick in slot 2 (ignore the A1, B1 stuff, just go by slot 1, 2, 3, and 4 for now).

    Now boot the system. Let us know if it boots with the 2021 and 2020 sticks.

  • cdotlucdotlu
    edited April 26

    thank you @TStandfield84 ! yes, i've tested this so many times :(

    each ram, each slot works perfectly. they can be boot up in pairs or one alone.

    but cannot boot when all 4 are popped in.

    it's so strange! and g skill thinks i's the manufactured dates on the labels. i reset the BIOs too and it didn't work.

    i originally had 2 sets (2x16gb)x2. 1 set got faulty, and i had it replaced. now the new set doesn't work with my current set.


    I'm gonna RMA the aug 2020 set :(

  • @cdotlu that's weird. If a 2020 stick in slot 1 and a 2021 stick in slot 2 will boot your system, I can't see how that's a manufacturing date issue; because it boots with with both stick together in the first 2 slots.

    It may be a motherboard RAM slot issue.

    What happened when you had 2021 stick in ram slot 1, 2020 stick in ram slot 2 and a 2021 stick in ram slot 3? RAM slot 4 is empty.

  • cdotlucdotlu
    edited April 27

    @TSTDavey wait a minute! i think you might have helped me figure out another faulty RAM? :-O

    when the 2020 stick boots alone, it all works. the pc is still registering 32GB when I boot the 2020 set. memory diagnosis tool doesn't have any errors either. but when I tried your suggestion...

    slot 1 2021 = good

    slot 2 2020 = good


    and then

    slot 1 2021 = good

    slot 2 2020 = good

    slot 3 2021 = good


    finally

    slot 1 2021 = good

    slot 2 2020 = good

    slot 3 2021 = good

    slot 4 2020 = yellow DRAM light idles


    super appreciative of you and @Ian !!!

  • @cdotlu Glad we could be of assistance and you're welcome. Its either a faulty RAM stick or slot for Slot 4.

    Let us know if still need any other suggestions from us.

  • @TSTDavey i'm soooo grateful for you and this forum. let's see what happens after my RMA, then I'll look into my ASUS B550-F ROG Strix Gaming (WiFi) AMD AM4 ATX Motherboard. it's also 8 months old and fairly new.

  • @cdotlu no problem, glad we could help. Was the B550 purchased from US (MC)? If so I'll email you for information regarding the purchase. I'm sure you have a warranty for the board.

  • hi again @TSTDavey! yup, i bought the RAM and B550 from MC's Brooklyn location. I still have the original email receipt too. It was purchased in August 2020 and should still be in warranty :)

  • IanIan admin


    ASUS should have a 3 year manufacturer's warranty on their motherboards.

  • Thank you @Ian and again @TSTDavey! Both of you are the best.

Sign In or Register to comment.