Bluetooth is not working - Powerspec G705


My bluetooth is not working all of a sudden. I have the ASRock 802.11ac Dual Band WiFi Adapter card. It shows off in windows but in the Bluetooth and other devices it does not give me the option to turn it on. The problem is when I go to the Device Manager it does not show Bluetooth and it gives an error in USB controllers section:

This happened previously on March 23rd of this year but I was able to unseat the ASRock Wifi Adapter card and put it back in and it worked. I have tried that several times and made sure the USB cable was snug on both the motherboard and the adapter card but that has not resolved the issue. I have tried to uninstall the drivers and reinstall them ( but I continue to get the error above (Unknown USB Device). I did power cycle (turn off the computer, unplug the power cord, hold down the power button for 30 seconds, etc) that was suggested on another thread but that did not resolve the issue. I tried to put the Wifi Adapter card in another slot but Windows could not find it at all in that slot. My Wifi does actually work but my guess is that works through the PCI Express slot which seems to be working fine.

I did put an off brand Wifi adapter from my sons computer in the same slot and connected it to the same USB connection on my motherboard and it works great. Unfortunately the cable is not USB on both ends of that Wifi adapter so I can't test to see if the cable is the issue. Any ideas, any help would be greatly appreciated?

I hope I am able to resolve this remotely as I live 6+ hours from the Micro Center store in Tustin, CA.


We love seeing what our customers build

Submit photos and a description of your PC to our build showcase

Submit Now
Looking for a little inspiration?

See other custom PC builds and get some ideas for what can be done

View Build Showcase


If You Can Dream it, We Can Build it.

Services starting at $149.99